Back to overview
Downtime
Band Pencil Unavailable
May 24, 2026 at 12:47pm UTC
Affected services
Band Pencil Platform
Member Portal
Client Portal
Emails
Resolved
May 24, 2026 at 1:17pm UTC
The issue has been resolved and all services are now fully operational.
Affected services
Created
May 24, 2026 at 12:47pm UTC
This issue was caused by an internal error with our hosting provider on the server that Band Pencil is hosted on. The disruption lasted for approximately 30 minutes, and Band Pencil should now be fully operational again.
Affected services